Jump to content
Sign in to follow this  
crgeorge

My new Grand Cherokee build

Recommended Posts

Hi all, I mentioned in a recent post that I would start a build thread here on Offroad passport for my 2002 Jeep Grand Cherokee overland. I've read through TheKsmiths build and it looks like it turned out pretty bad arse. I only hope mine turns out so good.

 

GrandcherokeeOverland800.jpg

 

So, here's what's in the works:

 

JK rubicon axle swap in the back,

NP231 swap w/ a 247 input and Teraflex SYE,

4:10 gears for the front D30 to match the rubi axle for now (hopefully soon to upgrade to an ARB and 30 spline chromoly's), and gusset the D30 C's and axle tube,

6 inch Clayton LA kit w/ bilstein shocks,

33 inch tires w/ 16x8 Moab rocker wheels,

new rear double cardan driveshaft,

Superlift speed modifier,

winch mount front w/ 8K Smittybuilt winch,

rear swing away tire carrier,

roof rack,

and more beef to the factory rock sliders.

 

 

Here's what already done:

 

Ham radio and CB radio installed (pictures to come),

switch panel where the ash tray used to be.

 

There are a couple other mechanicals that need to be addressed but so far I'm loving this jeep. V8 power and 21 MPG. I'm going to be working on the transfercase and/or welding on the new brackets for the rear D44. I'll post some pictures.

 

Chad.

Share this post


Link to post
Share on other sites

Hi all,

 

Here are some pictures of the Ham and CB mounts and my switch panel.

 

Switchpanel800.jpg

 

CBmount800.jpg

 

Hammount800.jpg

 

 

 

I'll use these switches for front and rear lockers, rock lights, and air pump.

 

Chad.

Share this post


Link to post
Share on other sites

I do not see pics, but your build list looks good. George:cool::D

Share this post


Link to post
Share on other sites

Yeah theres no pictures, you may me missing something :P

 

Sounds like a nice build though!

Share this post


Link to post
Share on other sites

No pictures? Hhmm, that's weird cuz I can see them. I know there's a way to add an image into the message w/out using attachments.

 

Chad.

Share this post


Link to post
Share on other sites

How about now?

 

Chad.

Share this post


Link to post
Share on other sites

your img urls reference attachments, but we can't see them, it's like the attachment is somehow not completely there or in some strange private limbo land only you can see... sorry, haven't seen this happen to anyone yet so not sure how to help!

 

if you have your photos already on a pic hosting service you can embed those here too, see "Option 2" here for more info: http://offroadpassport.com/forum/showthread.php?t=1354

Share this post


Link to post
Share on other sites

I tried option 2 lastnight before I went to bed. Hhmm. I guess I'll just attach them like option 1 although I plan on posting a lot of pictures as the build goes on and I'm affraid I'll use up my available space. I created a photobucket, lets try this now.

 

Chad.

Share this post


Link to post
Share on other sites
I tried option 2 lastnight before I went to bed. Hhmm. I guess I'll just attach them like option 1 although I plan on posting a lot of pictures as the build goes on and I'm affraid I'll use up my available space. I have my pictures on webshots, I was trying to avoid creating a new account elsewhere. I'll try to get it figured out after I get home today.

 

Chad.

 

You can bring them in from webshots using option 2.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...