Jump to content
Sign in to follow this  
thatoneguyaz

My 2004 Wj

Recommended Posts

So ran into some issues wheeling yesterday, which I kind of already expected as far as the tires go. Flexing out proved too much for my rear bumper, and I ended up having to zip tie it back on lol. Not even sure how to fix that to be honest, but for now, the zip ties work just fine. The bigger problem is on the way home it started over heating. I didn't want to risk actually over heating it so as soon as it was getting close to the red I pulled over and shut it off. The coolant was low, and my fan seems to be working really hard to try to keep everything cool. Is there two fans in all wjs? I've read some mixed things around the internet lol. I think the problem may be a cracked radiator, so now I'm looking into replacements.

Share this post


Link to post
Share on other sites

The fan set up depends on which motor you have. The 4.0's have only an electric fan and I belive the 4.7's have an Elecrtic and another fan (maybe hydrolic) but I could be wrong.

Share this post


Link to post
Share on other sites

my 4.7 has only the power-steering pump powered fan, i'm not sure if some earlier 4.7s or non tow-package 4.7s had a clutch and electric fan or not.

 

you could have something as simple as a radiator cap that isn't holding pressure or a thermostat that's stuck.

 

clean your jeep if possible and let it dry, be sure the cooling system is cold, then top of the radiator directly (not the overflow bottle), and if you have a 4.7 open the bleed hole and top off through there too. then bring it up to operating temperature, but don't let it overheat (so watch it closely). if there are really bad leaks then you should see them spray while it's at pressure. otherwise, if there are minor leaks in the radiator or hoses, you should find a white residue somewhere after they dry out later.

 

even if you have leaks, unless they are pouring out, then with a freshly filled radiator & block it should not overheat. if it starts to overheat even full of fluid, then you likely have other problems beyond a leak.

Share this post


Link to post
Share on other sites

Thanks for the replies, I swear I already typed a response out and posted it earlier...oops! It ended up being a crack in the top of the radiator. I got it replaced and now its running even a tad under 210, so all is well again. Now to fix my rear bumper lol.

Share this post


Link to post
Share on other sites

So haven't really updated much. I've finally got the sway bar disconnects fixed, and replaced a couple of tie rods thanks to Jeff again. Always appreciate his help so much. Next is going to be some control arm bushings that have worn out, both up front and in back. I definitely want to start working on some armor other than the skid plate I have up front.

 

16922035735_5ffa4ac901_b.jpg

Desert shot 1

16922039165_5f9ec83934_b.jpg

Stance!

16735848949_a27373358e_b.jpg

Favorite driveway pic

16734630360_4a16ceae40_b.jpg

The view

Share this post


Link to post
Share on other sites

Wow it has really been a year since I've posted here. Haven't added much to the Jeep. There are two leds in the grill now that have definitely made a difference. Now I want to add more when time and money permits.

Other then that, nothing much new to report. We take it on camping and wheeling trips whenever we can. One day I'll be able to afford dumping more $ into it, but that day has yet to come.

Share this post


Link to post
Share on other sites
So ran into some issues wheeling yesterday, which I kind of already expected as far as the tires go. Flexing out proved too much for my rear bumper, and I ended up having to zip tie it back on lol. Not even sure how to fix that to be honest, but for now, the zip ties work just fine. The bigger problem is on the way home it started over heating. I didn't want to risk actually over heating it so as soon as it was getting close to the red I pulled over and shut it off. The coolant was low, and my fan seems to be working really hard to try to keep everything cool. Is there two fans in all wjs? I've read some mixed things around the internet lol. I think the problem may be a cracked radiator, so now I'm looking into replacements.

 

LOL still haven't trimmed either... :eek:

 

Since this my radiator and some power steering hoses have been replaced.

Share this post


Link to post
Share on other sites

At least you're out enjoying it when you can! Great pics!

Share this post


Link to post
Share on other sites

Coming along nicely. It is a ton of work for sure, and you learn a lot (because you have to). But man is it fun. Great to see another WJ getting modded and USED :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...