Jump to content
Sign in to follow this  
irish1371

need help, new problem with the tj heater

Recommended Posts

Ok when I bought my LJ it only had high speed on the heater. I thought no problem, new resistor pack and good to go. I ordered a resistor from rock auto and slapped it in. I still have high spd and now once in a while low spd works but nothing else.

 

I cleaned my selector switch and checked for any obvious shorts without finding any. So I am down to an unknown style of problem or a bad resistor pack from rock auto.

 

I would love to have some other speed choices so it doesn't sound like a c-130 taking off inside the jeep every time I turn on the ac. Any ideas/ feedback would be great I'm about out of em myself.

 

 

Thanks

Irish

Share this post


Link to post
Share on other sites

I had the same problem on a 2001 TJ ... bought a new fan speed control switch and that fixed it .....

Share this post


Link to post
Share on other sites

any good spots to get one at? I was looking at rock auto but the details are light. It looks like I would be buying the knob and not the switch. now that would be anoying

Share this post


Link to post
Share on other sites

I think I bought it at the dealership ..... they are probably available all over the

internet now .....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...