Jump to content
theksmith

TheKSmith's 2003 Jeep Grand Cherokee WJ Limited 4.7 H.O. - The Do-It-All Rig

Recommended Posts

some more pics of Lafawnduh in UT, taken by dzJeepChic:

 

DSCN0320.JPG

 

DSCN0330.JPG

 

DSCN0479.JPG

 

DSCN0626.JPG

Share this post


Link to post
Share on other sites

Awesome pics of the rig, and congrats on 200k! Miles are just a number once enough work has been done, i.e. engine trans and axles.

:)

I'm trying to not rack up miles on mine since it sees about 3000 per year just heading to Colorado to wheel.

Share this post


Link to post
Share on other sites

 

i'll PM Joe on facebook and ask him if he has a part # for whatever he was talking about...

 

 

thanks Kris... any update?

Share this post


Link to post
Share on other sites
thanks Kris... any update?

 

just talked to him and he said he does have the info at the shop and will try to remember to send it to me tomorrow. however, i think i see that the back bottom bolt on the driver side is already seeping a bit again, not 100% sure though...

Share this post


Link to post
Share on other sites

Are those the original valve covers and you swapped them to the reman. engine? Was thinking it might be a cover problem and not the gaskets. Maybe they're warped?

Share this post


Link to post
Share on other sites
Are those the original valve covers and you swapped them to the reman. engine? Was thinking it might be a cover problem and not the gaskets. Maybe they're warped?

 

yes original covers. checked with straight edge when i did them and they don't appear warped at all. Joe also looked at them and didn't think there was any problem there.

 

i think they are magnesium for the H.O. engine, might have to throw some new regular plastic ones on if it needs to be done again - just to completely rule that possibility out.

Share this post


Link to post
Share on other sites

thanks Kris.

 

Bradywgn71 (Chris!): I have also purchased a reman engine. The covers that didn't leak on the old motor leaked on the new one. I replaced the covers (BOTH sets Magnesuim, OE on my 00 WJ, non HO) and 3 gaskets (even tried RTV). Im still getting leaking. I have not checked the heads for flatness yet

 

The problem is that oil collects at the #8 corner of the head and it just puddles there.

Share this post


Link to post
Share on other sites

Hmpf. Mine leaks also but I don't think from the valve covers. I think its more towards the front of the engine, I will have to take a closer look next time I'm in the barn. Speaking of reman engines, can you still get a new or reman 4.7 H.O.? Or parts to rebuild one ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...