Jump to content
shellback91

Small Evap Leak Code

Recommended Posts

I keep getting the "Small Leak" engine code on my JK. It pops up every 1 1/2 to 2 weeks. I have replaced the gas cap with no change.  I used to remove and replace gas cap then clear code and go about my day. Lately I just clear the code and move on. I am not a big wrencher so I am looking for a shop recommendation. I have a feeling taking it to the dealership may cost too much and be a run around but I could be wrong.

Edited by shellback91

Share this post


Link to post
Share on other sites
1 hour ago, theksmith said:

Give Joe a call at On Point Performance & Offroad - he's not too far from you: https://goo.gl/maps/SCYAZiEmbFfhe4Cx6

Thank you, I will give him a call.

1 hour ago, theksmith said:


 

 

 

Share this post


Link to post
Share on other sites

I had the same problem when I had my JK. I started with a new gas cap, then tightened everything I could find from the rear of the gas cap, all the way back to the gasoline tank. It turned out to be a plastic “snap-together” factory fitting. It was not securely fastened together. Why it didn’t throw a code much sooner, baffles me but, after making sure everything was tightened/fastened, I no longer had any more codes come up. Everything I checked was accessible by lying on a creeper and sliding underneath.

  • Like 1

Share this post


Link to post
Share on other sites

Same problem (code) on my JKU. Evap system leak. Also did the gas cap thing, inspection eliminated any loose connections. Have appointment with Joe @ OnPoint for the 14th. Will follow up with his diagnosis.  Al

Share this post


Link to post
Share on other sites

@Ghostrider- Thanks for the tip. I crawled under there earlier today and everything from the gas cap back is snug. I only saw one factory plastic "snap-together" fitting and that was secure too. I read some where to check the lines that run next to the battery for holes/wear and tear or loose connections, those look good to me too. I did recently replace my battery and thought something may have come loose during the swap. The code came up before then so probably not related anyways.

 

@mynr1 I may be making an appointment too pretty soon. Looking forward to hearing the diagnosis you get.  I am wondering if its the evap canister or something related to that.

Share this post


Link to post
Share on other sites

"small" evap leaks are typically difficult to find without a smoke machine. i haven't had any emissions issues on my JK yet, but with past rigs if the gas cap didn't fix it then it has always been a dry-rotted hose or rubber connector - i've never actually experience the pump, sensor, or canister go bad.

 

Share this post


Link to post
Share on other sites
2 hours ago, theksmith said:

"small" evap leaks are typically difficult to find without a smoke machine. i haven't had any emissions issues on my JK yet, but with past rigs if the gas cap didn't fix it then it has always been a dry-rotted hose or rubber connector - i've never actually experience the pump, sensor, or canister go bad.

 

Good point and thanks! I'm going to give Joe a call this week.  This issue is making me bonkers!! 😃

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...