Jump to content
shellback91

Drag Link Replacement

Recommended Posts

1 hour ago, 4WLNRN said:

I am still having my wobble issues after replacing the drag link and tie rods with the Apex Chassis 1 ton steering but it is more pronounced and is occurring more frequently.  So, hoping a new set of tires fixes it, as this is what the techs at HMC attribute it to as there was nothing that stuck out when they were going through the front end of my Jeep.  If not, I am back at square one.  Ugh.


Factory suspension? Could be trackbar or ball joints. Aren’t your tires pretty new BFG KM3 MTs?

 

You could test the theory and move the rear tires to the front and see if the problem still happens under the same conditions.

 

 

I had a similar experience when I installed my Clayton lift. Immediate death wobble. The new stronger components laid bare the underlying issues with my draglink TRE. You could be laying bare the weaknesses of other components.

  • Like 3

Share this post


Link to post
Share on other sites
10 minutes ago, 4x4tographer said:


Factory suspension? Could be trackbar or ball joints. Aren’t your tires pretty new BFG KM3 MTs?

 

You could test the theory and move the rear tires to the front and see if the problem still happens under the same conditions.

 

 

I had a similar experience when I installed my Clayton lift. Immediate death wobble. The new stronger components laid bare the underlying issues with my draglink TRE. You could be laying bare the weaknesses of other components.

Factory suspension and the tires are 3 years old.  and the good tires that were on the rear were moved to the front and the cupped tires were moved to the rear.

 

The track bar was the other thing that came to mind when I was looking up problems.  But the shop said my tires were done and needed replacing.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, 4WLNRN said:

Factory suspension and the tires are 3 years old.  and the good tires that were on the rear were moved to the front and the cupped tires were moved to the rear.

 

The track bar was the other thing that came to mind when I was looking up problems.  But the shop said my tires were done and needed replacing.


Nice! Sounds like you’re on the right track!

 

Looking forward to seeing if the new rubber fixes it for you man. Keep us posted!!

  • Like 2

Share this post


Link to post
Share on other sites
14 minutes ago, 4x4tographer said:


Nice! Sounds like you’re on the right track!

 

Looking forward to seeing if the new rubber fixes it for you man. Keep us posted!!

Will do and I hope that fixes it too.  Mat just have them throw a new track bar on when I am having the new tires put on

 

  • Like 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...